Как в Excel задать формулу

Довольно важной функцией в Excel являются формулы, которые выполняют арифметические и логические операции над данными в таблице. С их помощью можно легко решать математические и инженерные задачи, проводить различные вычисления, поэтому продвинутый пользователь программы должен знать, как в экселе задать формулу.

Простые формулы

Все формулы начинаются со знака равенства (=), это дает программе понять, что в ячейку вводится именно формула. К простым формулам относятся выражения, которые вычисляют сумму, разницу, умножение и т.д. Для написания таких выражений используются арифметические операторы:

— «*» — произведение (=4*3)
— «/» — деление (=4/3)
— «+» — сложение (=4-3)
— «-» — вычитание (=4+3)
— «^» — возведение в степень (=4^3)
— «%» — нахождение процента (для нахождения 4% от 156 используется такое выражение «=156*4%», то-есть при дописывании «%» к числу, оно делится на 100 и «4%» преобразуется в «0.04»).

Пример. Формула суммы в экселе:
Для ячейки A1 ввели выражение «=12+3». Программа автоматически провела исчисление и указала в ячейке не введенную формулу, а решение примера. Реализация других арифметических операций выполняется таким же образом.
В формуле можно использовать одновременно несколько операторов: «=56 + 56*4%» — данное выражение добавляет к числу 56 четыре процента.

Для правильной работы с операторами, следует знать правила приоритетности:
1) подсчитываются выражения в скобочках;
2) после произведения и деления считается сложение и вычитание;
3) выражения выполняются слева направо, если имеют одинаковый приоритет.

Формулы «=5*4+8» и «=5*(4+8)» имеют разные значения, потому что в первом случае изначально выполняется умножение «5*4», а в другом вычисляется выражение стоящее в скобках «4+8».

Формула excel среднего значения

Полезная формула, которая позволяет найти среднее значение нескольких введенных чисел и обозначается «=СРЗНАЧ()». Среднее значение чисел: 5, 10, 8 и 1 – это результат деления их суммы на количество, то-есть 24 на 4. Реализуется данная функция в excel таким образом:

Использование ссылок

Работа в программе не ограничивается лишь постоянными значениями (константами), поэтому формулы могут содержать не только числа, но и номера ячеек – ссылки. Такая функция позволит производить вычисления формул даже при изменении данных в указанной ячейке и обозначается ее буквой и номером.

Ячейки A1, A2 содержат числа 12, 15 относительно. При добавлении в ячейку A3 формулы «=A1+A2» в ней появится значение суммы чисел находящихся в ячейках A1 и A2.

Если изменить число любой из ячеек A1 или A2, то формула посчитает сумму исходя из новых данных и ячейка A3 изменить свое значение.

Диапазон ячеек

В excel можно оперировать определенным диапазоном ячеек, что упрощает заполнение формул. Например для подсчета суммы ячеек от A1 до A6 необязательно вводить последовательность «=A1+A2+A3…”, а достаточно будет ввести оператор сложения «СУММ()» и зажав левую кнопку мыши провести от A1 до А6.

Результатом работы будет формула «=СУММ(A1:A6)».

Текст в формулах

Для использования текста в формулах, его необходимо заключать в двойные кавычки — «текст». Чтобы объединить 2-а текстовых значения используется оператор амперсанд «&», который соединяет их в одну ячейку с присвоением типа «текстовое значение».

Чтобы вставить пробел между словами нужно записать так » =А1&» «&А2 «.

Данный оператор может объединять текстовые значения и числовые, так например можно быстро заполнить подобную таблицу, соединив числа 10, 15, 17, 45 и 90 с текстом «шт.»

10 комментариев для “Как в Excel задать формулу”

  1. Асель

    Excel позволяет использовать до 64 вложенных функций ЕСЛИ, но это вовсе не означает, что так и надо делать. Почему?

  2. Василий (iklife.ru)

    Excel моя давняя любовь. Иногда до абсурда вместо калькулятора пользуюсь таблицами Excel уже на автомате. Удобно, функционально. Рисую схемы, делаю расчеты, в общем, использую практически везде.

  3. Юлия

    Да, этой функции Excel нас учили в студенческие годы. Решали с ее помощью задачи. А теперь это незаменимый помощник в работе.

  4. Александр

    Приходится периодически заниматься с формулами и тут как раз эта статья кстати, иногда просто забываешь что и как в Excel )

  5. Светлана Вега

    Я часто смотрю статьи по Экселю. Иногда забываются знания,недавно сделала в экселе отличную таблицу -помощницу. Еще и другим людям помогает. Было бы круто, если б автор записал какое-нибудь видео по экселю )

  6. admin

    Спасибо за совет, это хорошая идея записывать видео, где все наглядно и понятно.

  7. Светлана Вега

    пожалуйста)

  8. Гаухар

    Здравствуйте, мне нужно создать формулы с ограничениями мах и мin и плавающими ставками все в одной формуле

  9. Денис

    Благодарю, что пишете полезные и нужные статьи.

  10. Людмила

    Спасибо за полезную статью! Все время хотела освоить эту науку)) Без скриншотов бы не разобралась. Отличный наглядный материал!

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *